Elaborazione
Loading
Articolo numero: faq-112 Articolo numero: faq-112

Come aggiornare PHP su sistemi CentOS Plesk (Approfondimento)

Posted on 06-04-2011 - By Admin  NTLab Italia Solutions

Per i più esperti:

wget -q -O - http://www.atomicorp.com/installers/atomic.sh |sh yum update php yum install php-soap yum install php-json /usr/local/psa/admin/sbin/websrvmng -a /etc/init.d/httpd reload

In caso si verifica l'errore di dipendenza per il php-sqlite2 (tipico per sistemi con Plesk), procedere come segue:

yum remove php-sqlite2 yum update php

verificare la versione PHP installata con:

php -v

Se l'aggiornamento e riuscito in modo corretto, si può installare php-sqlite2:

yum install php-sqlite2

In alcuni casi, potrebbe essere necessario modificare il file di configurazione php.ini

Procedere come segue:

cp /etc/php.ini /etc/php.ini_backup mv /etc/php.ini.rpmnew /etc/php.ini


Valutazione articolo

Torna a Ricerca